Jmeter plugins not installing for Jmeter 3.0

I was having issue with some missing class error and decided to uninstall and install new version of Jmeter.

I installed the Jmeter plugin manager and selected a plugin from available plugins to install and click on Apply Changes and Restart Jmeter. However I have tried this many times but the selected jmeter plugin does not get installed.

I even looked up on lib/ext folder to make sure the plugins have been installed. Not sure what the problem is here. My java version is 1.8.0_131. I have tried installing on both Jmeter 3.0 and Jmeter 3.3 but kept running into the same issue.

This is the Jmeter log file, if that is of any help -

INFO - org.jmeterplugins.repository.PluginManager: Restarting JMeter...2017/12/18 14:52:41 INFO - org.jmeterplugins.repository.PluginManager: Starting JMeter Plugins modifications 2017/12/18 14:52:41 WARN - org.jmeterplugins.repository.PluginManager: Failed to run plugin cleaner job java.nio.file.NoSuchFileException: C:\Users\Documents\Jmeter\apache-jmeter-3.0\lib\ext\jmeter-plugins-manager-0.18.jar
at sun.nio.fs.WindowsException.translateToIOException(Unknown Source)
at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
at sun.nio.fs.WindowsFileCopy.copy(Unknown Source)
at sun.nio.fs.WindowsFileSystemProvider.copy(Unknown Source)
at java.nio.file.Files.copy(Unknown Source)
at org.jmeterplugins.repository.ChangesMaker.getTempPmgrJAR(
at org.jmeterplugins.repository.ChangesMaker.getProcessBuilder(
at org.jmeterplugins.repository.PluginManager.startModifications(
at org.jmeterplugins.repository.PluginManager$

Sign In or Register to comment.